Results 1 to 4 of 4

Thread: Can anyone take a picture of the M4 Starter on a Blade 582?

  1. #1
    not real name 100 Club
    Join Date
    Oct 2009
    Location
    Sandbach, Cheshire
    Posts
    409

    Can anyone take a picture of the M4 Starter on a Blade 582?

    We are trying to see if the cog that drives the starter belt is missing a big washer that stops the belt coming off! It might have rattled loose. If anyone can take a picture of their Blade 582 Silvertop with M4 starter that'd be a great help. Specifically the cog!!

  2. #2
    Diamond geezer 500 Club
    Join Date
    Dec 2005
    Location
    North Cheshire UK.
    Posts
    2,532

    Can anyone take a picture of the M4 Starter on a Blade 582?

    Cant help with the 582 insulation Ian...but the drive from the starter on my 503 M4 has a big washer that will keep the belt on the motor...is there a tiny threaded hole in the end of the starter motor drive on yours,

    I do have some pics but as you can see they are not clear.

    Nick.

    Attached files

  3. #3
    not real name 100 Club
    Join Date
    Oct 2009
    Location
    Sandbach, Cheshire
    Posts
    409

    Can anyone take a picture of the M4 Starter on a Blade 582?

    I just remembered I didn't reply!! Thanks for that, it was perfect. Showed the starter cog perfectly.

  4. #4
    Diamond geezer 500 Club
    Join Date
    Dec 2005
    Location
    North Cheshire UK.
    Posts
    2,532

    Can anyone take a picture of the M4 Starter on a Blade 582?

    Dont forget the main drive clutch that fits on the crank end needs greasing every 50 hours as its rotating all the time the engine is running,

    Have you got the instructions for it ???
    Nick.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •